Did you know if you are running uniFLOW V5.2 the official support from Canon and NT-ware ends in April 2018? In preparation, we’re taking a look at your options to help you decide what to do. Should you upgrade, replace, or do nothing at all?

Read More